Nicholas Morrison - Networking Specialist

flokinet-013 - MLAG - Multi-chassis Link Aggregation Groups

Connecting to the lab server

Open your favourite Terminal Emulator

SSH to the netlab server:

$ ssh-keygen -R netlab.nanocat.net   <- delete the cached fingerprint
                                        (lab server rebuilt frequently)
$ ssh [email protected]
Password: (generated fresh each week)

List the running containerlab devices:

$ sudo containerlab inspect --all

Connect to an Arista device:

$ sudo docker exec -it clab-device–name Cli

.. or connect to a Linux device:

$ sudo docker exec -it clab-pcXX-name bash

Goals

  • Configure MLAG

Multi-Chassis LAGs: part 1

  • Make an MLAG VLAN (both switches)
!
vlan 4094
   trunk group mlagpeer
!
interface eth25
   switchport mode trunk
   switchport trunk group mlagpeer
!
no spanning-tree vlan 4094
!

Multi-Chassis LAGs: part 2

  • Configure the L3 VLAN interface (both switches)
!
interface vlan 4094
   ip address 10.0.0.x/30
!
  • Configure MLAG settings
!
mlag
   local-interface vlan 4094
   peer-address 10.0.0.x          <- the other switch's MLAG IP
   peer-link ethernet25
   domain-id mlag1
!

Multi-Chassis LAGs: part 3

  • Create MLAG interfaces on both switches
!
interface eth1
   channel-group 1 mode active
!
interface po1
   mlag 1
!

Multi-Chassis LAGs: part 4

  • Create your LACP interfaces on the client switch
!
interface ethernet23-24
   channel-group 23 mode active
!
! ^ This creates a new virtual interface, Port-Channel23
!
interface Port-Channel23
   switchport mode trunk
   switchport trunk allowed vlan 35-39,56,100
!

Check MLAG config

show mlag status
show mlag config-sanity
show mlag interface