S1E13 - Back Into the Tangled Web

title: S1E13 - Back Into the Tangled Web
author: Nicholas Morrison
draft: false
tags: [network, workshop, routing]
categories: [workshop]
noindex: true

Connecting

Connect to the lab server:

local$ ssh-keygen -R netlab.nanocat.net
local$ ssh [email protected]
Password: (see discord)

Connect to your router:

lab@netlab$ list-routers                           <- list all lab routers
lab@netlab$ list-pcs                               <- list all lab PCs
lab@netlab$ docker exec -it clab-clintro-r7 Cli    <- connect to your router

Topology

Topology: a tangled web
Topology: a tangled web

Goal

Steps (Bird’s-Eye View)

Configure the IPs

Refer to the diagram.

10.(lower router number).(higher router number).(this router number)/24

example: r1 to r3. r1:eth1 (10.1.3.1/24) -> r3:eth3 (10.1.3.3/24)

example: r10 to r5. r10:eth4 (10.5.10.10/24) -> r5:eth1 (10.5.10.5/24)

also create a loopback interface (r1 = 1.1.1.1/32, r6 = 6.6.6.6/32, etc):

Create your loopback interface

Example for r10:

!
interface loopback1
   ip address 10.10.10.10/32
!

Enable RIP

!
router rip
   no shutdown
   network 10.0.0.0/8
!

This network line will include any interface with an IP address in the 10.0.0.0/8 range (ie, any address starting with a 10)

Run a traceroute from r1 to r11

r1#show ip route
r1#show ip route 11.11.11.11
r1#traceroute 11.11.11.11
...

Shutdown an interface to force the route to change

On r1,

!
interface eth2
   shutdown
!

Then show ip route, and traceroute again.

r1#show ip route
r1#traceroute 11.11.11.11

Shutdown an interface on another router

On r1,

!
interface eth2
   no shutdown
!

On r5,

!
interface eth4
   shutdown
!

Traceroute!

Enable OSPF

On all routers:

router ospf 100
   ! run ospf on *every* interface
   network 0.0.0.0/0 area 0
!

Traceroute!

Shutdown an interface

!
interface ethX
   shutdown
!

Traceroute!

Adjust interface costs

See costs:

rX#show ip ospf interface brief
(observe the COST field)

Change costs:

!
interface ethX
   ip ospf cost 432
!

Check the change:

rX#show ip ospf interface brief

Check your routing table, traceroute!

michel - R3 roumen - R5 chris - R6 nick - R7 kim - R8 sammy - R9 hans - R10 ryan - R11