title: flokinet-013 - MLAG - Multi-chassis Link Aggregation Groups |
author: Nicholas Morrison nick@nanocat.net |
draft: false |
tags: [network, workshop, arista] |
categories: [workshop] |
noindex: true |
Open your favourite Terminal Emulator
SSH to the netlab server:
$ ssh-keygen -R netlab.nanocat.net <- delete the cached fingerprint
(lab server rebuilt frequently)
$ ssh lab@netlab.nanocat.net
Password: (generated fresh each week)
List the running containerlab devices:
$ sudo containerlab inspect --all
Connect to an Arista device:
$ sudo docker exec -it clab-device–name Cli
.. or connect to a Linux device:
$ sudo docker exec -it clab-pcXX-name bash
!
vlan 4094
trunk group mlagpeer
!
interface eth25
switchport mode trunk
switchport trunk group mlagpeer
!
no spanning-tree vlan 4094
!
!
interface vlan 4094
ip address 10.0.0.x/30
!
!
mlag
local-interface vlan 4094
peer-address 10.0.0.x <- the other switch's MLAG IP
peer-link ethernet25
domain-id mlag1
!
!
interface eth1
channel-group 1 mode active
!
interface po1
mlag 1
!
!
interface ethernet23-24
channel-group 23 mode active
!
! ^ This creates a new virtual interface, Port-Channel23
!
interface Port-Channel23
switchport mode trunk
switchport trunk allowed vlan 35-39,56,100
!
show mlag status
show mlag config-sanity
show mlag interface